Questions fréquentes (FAQ)

Poser une question

Quelle est la compatibilité entre la version de l'atelier de programmation ZELIOSOFT et la version de firmware du module ZELIO logique


Deux cas très différents dans leurs effets sont à détailler :
 

  • transfert du fichier programme du PC vers le module ZELIO,
  • transfert du fichier programme du module ZELIO vers le PC.

TRANSFERT du PC vers le module ZELIO

Il s'agit du cas où l'utilisateur a acheté un relais ZELIO et souhaite le programmer avec le logiciel ZELIOSOFT2 résident sur son PC

Il est nécessaire de vérifier la version du firmware du relais Zelio
 


 

  • si la version de firmware du relais Zelio est inférieure strictement  à V4.04, toutes les versions de l'atelier de programmation ZELIOSOFT peuvent être utilisées pour le programmer et ce, sans restriction,
    Il s'agit de relais ZELIO commercialisés avant Janvier 2012
  • si la version de firmware est supérieure ou égale à V4.04, il sera nécessaire d'utiliser une version de ZELIOSOFT au moins égale à V4.5.
    En effet, le hard du ZELIO a évolué en Juillet 2011, évolution non prise en compte par les versions de ZELIOSOFT inférieure à V4.5 .
    Les relais ZELIO actuellement commercialisés comportent tous des firmwares de version supérieures ou égales à V4.04.
Attention, le fait de transférer une version de firmware dans le relais ZELIO écrase le programme.

 TRANSFERT du module ZELIO vers le PC

Il s'agit du cas où l'utilisateur souhaite récupérer un programme dans le relais ZELIO pour pouvoir ensuite le modifier avec le logiciel ZELIOSOFT2 installé sur son PC.

En ce cas, il est nécessaire d'utiliser une version de ZELIOSOFT2 en rapport avec la version du firmware du relais ZELIO.

Les compatibilités sont les suivantes :

  Version du Firmware du relais programmable ZELIO
Version de Zeliosoft V2.XX V3.XX <V4.04 ≥ V4.04
V2.04 Compatible Non compatible Non compatible Non compatible
V4.01 Non compatible Compatible Non compatible Non compatible
V4.01 Non compatible Non compatible Compatible Non compatible
V4.5 Non compatible Non compatible Non compatible Compatible

 

Exemple: si l'utilisateur souhaite modifier un programme installé dans un ZELIO acheté en 2009 est de version de firmware V3.xx, il lui faudra absolument disposer d'une version ZELIOSOFT V3.
 



 

Cela vous a-t-il aidé ?
Que pouvons-nous faire pour améliorer l'information ?